Running in senior mode, but cannot access my YaCy from public address

Hi,

I’ve just installed YaCy on the latest Linux Mint, and I can see my YaCy page on localhost:8090. I’ve opened the port on my router (BBox Proximus), the mint firewall is disabled as it is by default, and I’m crawling the web as I speak. It’s says I’m running in senior mode. So everything seems to be fine in terms of connectivity, except I cannot a access YaCy through my public IP.

What did I forget?

Thank you.