Firefox can't connect to http://localhost:8090/ after restarting system

Good afternoon everyone.
I post since I’ve been trying to use YaCy but failed every time I restarted my computer.
When I install YaCy, everything works fine, but as soon as I restart my computer, it stops working.
I do

cd yacy
./startYACY.sh

and I get

****************** YaCy Web Crawler/Indexer & Search Engine *******************
**** (C) by Michael Peter Christen, usage granted under the GPL Version 2  ****
****   USE AT YOUR OWN RISK! Project home and releases: http://yacy.net/   ****
**  LOG of       YaCy: DATA/LOG/yacy00.log (and yacy<xx>.log)                **
**  STOP         YaCy: execute stopYACY.sh and wait some seconds             **
**  GET HELP for YaCy: join our community at https://searchlab.eu            **
*******************************************************************************
 >> YaCy started as daemon process. Administration at http://localhost:8090 << 

None the less, Firefox tells:

Unable to connect

Firefox can’t establish a connection to the server at localhost:8090.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

I’ve had the same problem both with Linux Mint and MX Linux.

Is there anything I’m doing wrong??

Regards.

Maybe the logs can help: DATA/LOG/yacy00.log