Does anyone know how to install an SSL certificate in a yacy peer

Any easy instructions would be greatly appreciated… Trying to get peer access through my webpage yassen.com can make it work but all browsers say my site is malware now…

Thanks
peer yassen

Have you resolved the issue? I’m able to access the link posted: https://yassen.com/ without any apparent problems.

I think I have an old cert… but it works… still have problems saying its malware with some browsers…

Its the old cert 2013 that came with the version 1.92 any one know how to install a current SSL
Cert?

I don’t know what you mean by “peer access through my webpage”, but the cert for your website appears to be valid, though due for renewal. It expires in one month.

If YaCy itself, somehow set up as a server or something has it’s own internal ssl certificate I don’t know.

My best guess is you are loading the YaCy interface into an Iframe. That doesn’t seem to be working. The iframe is targeting itself, apparently. I’m not sure that is valid HTML but that has nothing to do with the ssl certificate.

It may be that some browsers are visiting http://yassen.com (not https…) which may produce a warning in some browsers “connection is not secure” or some such, if you do not force https.

Also, if I copy the URL you have in your Iframe to visit it directly, there is no response from that IP Adress.

When I said previously that the page seemed OK, I did not know there was any content other than the links at the top, Are you sure the computer at the address in the Iframe is accessible from the internet?

If it is not accessible directly, it can’t load in an Iframe either, I don’t suppose. Your ISP or router or something may be blocking that port. Normally I would use a dynamic DNS service when using a “home” server. If that is the case, your ISP can change your IP address then the link in your Iframe will end up pointing so some other computer when the address is reassigned, possibly to your neighbors computer or who knows where. Anyone using the same Internet service provider.

OK. The IP address in your Iframe 192.168.11.32 is not a public address. It is reserved for private use by anyone on an internal network or LAN. I’m guessing if you want to make that computer accessible you will have to use some sort of port forwarding.

edit: Unless you are setting up a network of YaCy peers on a LAN or something. I have been working pell mell on a conceptual search engine for years, that I had hopes one day of making peer-to-peer that could be enabled to run on a semi-localized mesh network.

Independent mesh networks are cropping up on university campuses and cities all over the world. At some point I had the idea that there should be some distributed search technology for such off-the-grid mesh networks. I think I had posted that Idea on Twitter a year or two ago.

I think it is ludicrous that here in New York when I fire up my laptop I see about two dozen private Wi-Fi Routers in this part of town… Every one password protected. The phone companies discourage sharing connections or operating a “hot spot”. That would cut into the bottom line I suppose, but I worry about WiFi pollution from the saturation of Electromagnetic waves. I think free Mesh Networks are a wonderful thing and the way the internet should be, as much as possible.

OK you are correct… The iframe code that yacy provided works great on my LAN… But I need to forward the port to a public port… Not that good at linux/ubuntu but was able to set up a peer on my home network and put the iframe code on my homepage of my website yassen.com

the home ip running the yacy peer is…
https://192.168.11.32:8443

the code for the iframe reads…

How do I push the iframe though a port available to the public?

Thanks Yassen

I’ve found to post HTML code the brackets need to be removed in this forum, or I think it can be edited by replacing the brackets with < and >

That is & l t ; and & g t ; without the spaces. (less than and greater than)

This would result in:

<iframe name=“target” src=“https://192.168.11.32:8443/index.html?display=2&resource=local” id=“target” frameborder=“0” height=“1200” scrolling=“auto” width=“100%”> </iframe>

I can only guess at what kind of setup you have and what exactly you’re trying to do. I have managed to set up a working web-server accessible on the internet from my home network through a firewall using port forwarding and a dynamic IP service.

As I remember it was one of the hardest networking challenges I’ve ever run into but after much trial end error It was possible and I was then able to post links to my website and serve web pages from my home server. It was rather complicated and that was a long time ago. I’m having the same or a similar problem now in that My YaCy instance is not visible to other peers. So we are kind of in the same boat at the moment.

I believe it is also very much OS and router specific so what works on my setup may not work on yours and vice versa. Also some ISP’s intentionally block that sort of thing. It may be against their “terms of use” even. I discovered this when using my phone as a hot spot. It worked fine but when reading the fine print for my phone service i found that it was against their user agreement policy.

There should be some url to connect to your router but messing with the router settings could cause problems if you are not sure what you are doing in there.

Unfortunately I’m, as I said, having much the same issue at the moment and have not had the time to figure it out as I’ve been extremely busy with other projects taking priority at the moment.