Cannot change password

Hi – I am unable to change my password or access the dashboard.

I originally set a password with a % sign as part of the password, I believe this broke it.

I have tried to follow the instructions in the FAQ –
Linux - Ubuntu
command line, inside yacy/bin ./passwd newpassword
It then asks me for existing host admin password, which I do not know and after I put the last known password (the one I am attempting to set) in – I get

Password reset while YaCy is shut down: edit the file DATA/SETTINGS/yacy.conf:
Setting new YaCy administrator password…
YaCy server appears to be running. Calling the ConfigAccounts_p API…
Enter host password for user ‘admin’:
curl: (22) The requested URL returned error: 401
curl: (22) The requested URL returned error: 401

I have to kill the search daemon because yacySTOP wants a password. So I kill the ahahi-daemon and follow the next procedure:
When I try the yacy.conf procedure … first there is not “serverAccountBase64MD5” entry

  • remove the entry serverAccountBase64MD5
  • remove the entry adminAccount (if any)
  • choose a new password by setting the entry serverAccount to :, for example serverAccount=admin:mysecretpassword

Then I remove the adminAccount entry and add the serverAccount=admin:newpassword

and restart and it does not recognize the newpassword, but does change the config file to reflect the adminAccount=admin

Any one have any ideas ?

Hi Jack,

I have the exact same problem.
Did you find a solution?

Thanks,
Stephan

Hello, try to run bin/passwd.sh and leave current password blank (by default, authorization not required from localhost/ssh)

Guten Abend dear YACY community

The YACY password reset with ./passwd.sh is running while YACY is stopped:

YACY /opt/yacy/bin/

./passwd.sh

/opt/yacy/bin# ./passwd.sh
Setting new YaCy administrator password…
Please enter the new password for user ‘admin’ :
YaCy server appears to be shutdown. Modifying the configuration file at /opt/yacy/DATA/SETTINGS/yacy.conf…
Password successfully changed for User Name ‘admin’.

I needed two restarts of YACY to login into YACY with the new password.

In the file yacy.conf, write: adminAccountForLocalhost=true instead adminAccountForLocalhost=false, and go in the localhost.